Microsoft FrontPage 2003
Web Site Design and Development

Written and Edited by
James Sharpe and Kendra Lebel

September 1, 2005, Version 1.0
Additional Resources

Visit Our Website!

http://cgweb.pacarea.uscg.mil/training

Click on your district and follow the links on the left to...

- View the upcoming schedule
- Register for classes
- Download additional copies of manuals
- Connect to some great sites though our “Useful Links” page
- Get answers to some of the frequently asked questions
- Contact us with your questions and comments

Try the Coast Guard Google Search Engine

There is an easier way to tap into the vast resources available on the Coast Guard Intranet! Partnered with Google, the Coast Guard has implemented an extremely powerful search engine that catalogs all information published on the intranet, Coast Guard Wide!

http://cgweb.search.uscg.mil

This document is copyrighted. It may not, in whole or part, be copied, duplicated, reproduced, translated, electronically stored, or reduced to machine readable form by anyone outside of the United States Coast Guard without prior written notice by the United States Coast Guard. Additional copies of this handout are available. Contact the USCG, Pacific Area Computer Training Team, Seattle, WA at (206) 217-6196.
# Table Of Contents

**Planning And Designing A Web Site** ................................................................. 1  
  Understanding Web Terminology ................................................................. 2  
  Using FrontPage Server Extensions ......................................................... 5  
  Planning Effective Web Pages ................................................................. 6  
  Overview Of The FrontPage Window ...................................................... 11  
  Using Toolbars ..................................................................................... 12  
  Using Shortcut Keys ........................................................................... 13  
  Getting Help ....................................................................................... 14  

**Creating A New Web Site** ............................................................................. 15  
  Creating A FrontPage Web Site ............................................................... 16  
  Hide And Display The Folder List ............................................................ 17  
  Managing Files And Folders .................................................................... 18  
  Creating Web Pages Using Templates ....................................................... 19  
  Creating Blank Web Pages ..................................................................... 20  
  Saving Pages .......................................................................................... 21  
  Changing Page Views ........................................................................... 22  
  Previewing Web Pages .......................................................................... 23  

**Managing Web Pages** .................................................................................. 25  
  Changing The Page Title .......................................................................... 26  
  Formatting Text ..................................................................................... 27  
  Using The Format Painter ......................................................................... 30  
  Creating Numbered And Bulleted Lists ................................................... 31  
  Creating Definition Lists ......................................................................... 32  
  Changing Background Colors .................................................................. 33  
  Adding Background Images ..................................................................... 34  
  Inserting Horizontal Lines ...................................................................... 35  

**Hyperlinks** ................................................................................................ 37  
  Creating Bookmarks ............................................................................... 38  
  Inserting Hyperlinks ............................................................................. 39  
  Changing Hyperlink Colors .................................................................... 41
Graphic Images.....................................................................................................43
Optimizing Images For Web Use .................................................................44
Inserting Graphic Images..............................................................................45
Inserting Clip Art .........................................................................................46
Utilizing The Pictures Toolbar .................................................................47
Resizing And Aligning Images ...................................................................50
Cropping Images .........................................................................................51
Adjusting Graphic Image Layout .............................................................52
Adding Text Alternatives To Images .........................................................53
Adding Thumbnail Images ..........................................................................54
Creating An Image Map .............................................................................55
Creating Photo Galleries ..........................................................................56
Inserting Video Clips ..................................................................................58

Web Site Management ..................................................................................59
Correcting Accessibility Issues .................................................................60
Overview Of Publishing A Web Site .........................................................61
Publishing Files .........................................................................................62
Creating A Task List ..................................................................................63
Analyzing A Web Site With Reports .........................................................65
Using Spell Check ......................................................................................66

Appendix A: Keyboard Shortcuts ...............................................................67
In this section, you will learn more about:

- Understanding Web Terminology
- Using FrontPage Server Extensions
- Planning Effective Web Pages
- Overview Of The FrontPage Window
- Using Toolbars
- Using Shortcut Keys
- Getting Help
Understanding Web Terminology

What is the Internet?

The Internet is a worldwide network of computers. First rolled out as ARPANET in 1969, the Internet has moved from a military network to an academic research network to the current commercial network system. It commonly supports services such as e-mail, the World Wide Web, file transfer and Internet Relay Chat.

What is the Intranet?

An Intranet is a private network that is contained within a company or organization. It may consist of many linked local area networks and also use leased lines in the Wide Area Network. Typically, an intranet includes connections through one or more computers to the outside Internet. The main purpose of an intranet is to share organizational information and computing resources among employees and organizations. Intranets use the same technology as the Internet but limit access to specific users and provide a high level of security for sensitive organizational data.

What is the World Wide Web?

The World Wide Web (WWW) is a system of Internet servers that support specially formatted documents. In the simplest of form, the documents are formatted in a language called HTML (Hypertext Markup Language) that supports links to other documents, as well as graphics, audio, and video files. This means you can jump from one document to another simply by clicking on links. Not all Internet servers are part of the World Wide Web. For example, there are Internet Server dedicated to e-mail, chat, file transfer and news groups.

What is a Web Page?

A Web Page is created using one of many web programming languages and is a single document that is available via the Internet or Intranet. These web pages generally resided on a Web Server. A user requests a web page from a web server through their web browser by either clicking on a hyperlink or typing in a particular web address. A web page can contain text, images, sound files, video files and hypertext links to other Internet pages.

What Is a Browser?

A Browser, also referred as Web Clients, is a software program that acts as an interface between the user and the technology used in the World Wide Web. The browser contacts a web server and sends a request for information. Once the information is received, it interprets the web page code and then displays it on the user’s computer. Popular web browsers include Microsoft Internet Explorer, Mozilla Fire Fox and Netscape Navigator.
Understanding Web Terminology

What is HTML?

HTML stands for *Hypertext Markup Language*. It consists of standardized codes, or “tags” that are used to define the structure of information on a web page. HTML defines several aspects of a web page including heading levels, font formatting, images, paragraph breaks and hyperlinks to other resources.

HTML files can be written in any text-editing program, for example, Notepad and Microsoft Word. HTML files can also be written using a HTML editor, such as Microsoft FrontPage and Macromedia DreamWeaver. Below is an example of what the code on a simple web page may look like. Note that all the HTML tags are enclosed in `< >`.

```html
<HTML>
<HEAD>
<TITLE>HTML Example</TITLE>
</HEAD>
<BODY>
<H1>An Example Of HTML Code</H1>
<P>HTML is a <I>base level coding language</I>.</P>
<H2>This is an image example.</H2>
<img border="0" src="images/logo_frontpage.gif" WIDTH="301" HEIGHT="79"/>
</HTML>
```

HTML is considered a base level code and is actually pretty easy to learn. You will often see other web pages with much more complex code used to design them. Often these codes are included in the base level HTML code. Examples would be ASP, JAVA, PHP, CGI and Visual Basics, just to name a few.
Understanding Web Terminology

What is an URL?

URL stands for Uniform Resource Locator. It identifies a particular Internet resource, e.g.: a web page, a ftp server, an image, a text file, etc. It is a standardized addressing format for Internet or Intranet resources and helps users locate these resources by indicating exactly where they are. Every resource available via the WWW has a unique URL. Think of it as the address for your house. No two addresses in the world are the same.

URLs will never have spaces in them and, on some network systems, are case sensitive. (Coast Guard servers are not case sensitive.) The basic structure of a URL is hierarchical, and the hierarchy moves from left to right.

http://www.gocoastguard.com/information/faq.html

Once upon a time, there were only a handful of different domain name extensions to choose from. You could choose between .com for commercial organizations, .net for network services and .org for non-profit organizations. In addition, many countries offered domains based on the two-character ISO country codes, such as “.fr” for France, “.jp” for Japan, “.ca” for Canada and so on.

In recent years, the pictures has become more complicated, with more and more domain names and alternatives springing up. The Internet Corporation For Assigned Names and Numbers (ICANN) controls which domain names are available and is constantly adding new ones. A quick search on the internet shows that about 273 top level domains are available. To understand how complex this gets, just take a look at the new ones that have been recently added.

- .aero for Air-transport industry
- .biz for Businesses
- .coop for Cooperatives
- .info for Unrestricted Use
- .museum for Museums
- .name for Individuals (you can now have www.johnsmith.name)
- .pro for Accountants, Lawyers, and Physicians
Using FrontPage Server Extensions

FrontPage 2003 uses Server Extensions from Microsoft. FrontPage Server Extensions are scripts that are stored on the web server that add to the functionality of FrontPage. These extensions support features such as hit counters, data collection and e-mail processing. When creating web pages that use these components, you will insert what is called Browse-Time Web Components.

Outside the Coast Guard network, you should not use browse time components if you are using a web server that does not have FrontPage server extensions. FrontPage Server Extensions are installed on the Coast Guard network, although, there is a possibility that the server extensions may stop working, become corrupt or be removed from the server in the future. If this happens there are several features that will stop working on your web page:

- Search Forms
- Hit Counters
- Database Access
- Confirmation Fields
- Discussion Form Handlers
- Registration Form Handlers
- Save Results Form Handlers
- Photo Galleries

You can turn support on or off for features in FrontPage 2003 that require FrontPage Server Extensions. If you turn support off, features that require FrontPage Server Extensions will not be available as menu options.

▶ STEPS: To enable or disable Server Extension support:

1. Click on TOOLS ⇒ PAGE OPTIONS.
2. Click on the Authoring tab.
3. Do one of the following:
   - To turn support on for features that require FrontPage Server Extensions, select the Browse-time Web Components check box.
   - To turn support off for features that require FrontPage Server Extensions, clear the Browse-time Web Components check box.
Planning Effective Web Pages

A web page is a place people visit to obtain information. When you design a web page, think about such things as purpose, organization and style. Below are several guidelines to help you.

Simplicity

Keep your web pages simple and uncluttered. Your information should be clear, concise, and to the point, while being pleasant and interesting. Avoid presenting unnecessary information. Resist the temptation to clutter up your screens with too much information. It is better to have two uncluttered pages than one crowded page.

Consistency and Predictability

Visitors feel more comfortable if you maintain a consistent look and feel throughout your site. It also lets visitors know they are still at your site. Use a consistent style for text and graphics and stick with it throughout. Repeat certain visual or design elements on every page in your web site. You might repeat colors, graphics, layouts, navigation bars, etc.

Similar functions should appear in the same relative location on all screens. The navigation buttons on your homepage are often set up in a way you can't repeat on other pages, perhaps because the homepage is the “cover” of the web site and usually has a different visual arrangement than the content pages. But once you get to content pages, the visitor should find the navigation in the same place, in the same order, with the same graphics. This makes it easy for visitors to find their way around in your site.

Clarity

The Organization of your site should be clear to visitors. The Purpose of the web pages elements should be clear at a glance. The Navigational system should be clear and easy to use. Visitors should not have to try to figure out how your navigation system works. Navigation is often difficult on the web. Poorly designed pages cause users get lost and to not be able to find the information that they are looking for. Clarity begins with proper planning (and is optimized by simplicity).

Put a Title (sometimes called a Header) on each page. It doesn't need to be large and bold, as long as it's recognizable as a title, separate from the rest of the page content.
Planning Effective Web Pages

Readability:
The most difficult place to read text is on a computer monitor. To make your web pages as easy to read as possible, make the following adjustments to text on web pages:

Layout
Optimize your text for the way users read on the web. Most people do not read web pages word by word. Instead, they scan the page, picking out individual words, sentences and hypertext links. They skip over text they deem to be fluff (welcome messages, intro paragraphs, etc). One study found that 79% of users only scanned new web pages; only 16% read word-by-word. To optimize your text for web-reading, make your text “scanable” by:
- Highlighting keywords by using variations in font type, color and size.
- Creating meaningful sub-headings.
- Using bulleted lists when appropriate.
- Keeping to one idea per paragraph (users will skip over any additional ideas if they are not caught by the first few words in the paragraph).
- Using less text. Try to use half the word count (or less) than conventional writing. Be very concise!
- Create an outline-like presentation.

Ease of Reading
Black or dark text on a white or off-white background is the easiest text to read. Text must have good contrast with the background in order to be easily read.

For headings and titles, a Sans-Serif typestyle such as Arial or Helvetica is best. For body text, a Serif type style, such as Times New Roman, is the easiest type style to read.

Avoid using blinking or flashing text. People notice motion more readily than color or size. Blinking text on a page will draw a reader's eye away from all other text or image content. And in case you are not aware of this already, blinking, flashing, spinning, scrolling text is also annoying!
Planning Effective Web Pages

*Backgrounds*
When choosing a background, whether plain or textured, make sure your text is readable. Many web sites have backgrounds that are very distracting. This can prevent visitors from reading your pages. Also, avoid bright or fluorescent colors… both for text and backgrounds…actually, for anything.

*Text Style*
Avoid putting phrases, whole sentences, and paragraphs in ALL CAPITAL LETTERS. Why? Because text in ALL CAPS is much harder to read than text that is upper and lower case. (It has been proven that we tend to read the actual shape of the word itself and all caps make it difficult to see the shape of a word.) Overall, it makes reading text on a webpage very UNFRIENDLY to your visitors.

It's OK to make one or two words in all caps, preferably, small words. All caps is also equated to verbally shouting, which instantly annoys some readers. Most importantly, you lose the effect of emphasizing the important point if everything is capitalized. Readers will have a very difficult time determining which key words are important if everything looks the same. If you wish to emphasize something use:

- **bold lettering**
- “quote marks”
- a larger text size
- a different color
- **combinations** of the above

*Avoid or Minimize the use of Animations*
They may be cute, but animations are usually completely worthless on your site. They contribute little or no value as they can ruin your web pages by potentially annoying your visitors.

Our minds treat motion as a high-priority visual stimulus. Thus, animations distract from our ability to read text. They quickly become annoying, especially if overused, because they draw attention to themselves. Focusing on a site's content can be very difficult when images are blinking, flashing, spinning, bouncing and rolling around, essentially screaming: “LOOK AT ME!” Use animations sparingly - if at all. They are usually best to avoid, especially on pages with several paragraphs of text.

*Caution*
Avoid or be careful of using underlined text for emphasis since it can be easily confused with a hyperlink. You always want to avoid underlined words if the text color is blue. This is the default color for hyperlinks in most browsers.
Planning Effective Web Pages

Ease of Use

All of the previous design concepts combine to produce Ease of Use, also known as “User Friendliness” and “Usability.” On every page of your site, answer two basic questions your visitors will ask themselves:

“Where am I?”
“Where do I go from here?”

Every page on your site should have some sort of website and page identification (a name or logo that announces, “You are here.”) plus a link to your homepage. Often times users will find your site from a CG Google search or through a link on someone else’s website (versus coming straight to your homepage) so these identifying features will be very helpful. If you do not have website and webpage identification, users can quickly become lost and frustrated.

If possible, try to have multiple ways of easy navigation. If your pages are consistently longer than 1½ screens, consider adding navigational links throughout to help readers jump to other (topics?) (pages?) without forcing them to scroll up to the top of your page. Also consider repeating navigation links at both the top and the bottom of your pages. If you think that repeating navigational links look awkward, try a simplified version that offers only essential destinations.

Speed

Most people do not like waiting for pages to download. So design your pages so they will download as quickly as possible. This can be done by using graphics sparingly, optimizing your graphics for web use and keeping pages short.

Navigation

Create an outline /flowchart and base your site structure upon this. Consider using Microsoft Visio (PacArea classes are available) to help with this process.

Your buttons and navigational links should be clearly marked. If a graphic image is a button, it should be look like it is a button. The interaction technique (clicking) is easy, but it is not easy to know what to click on or where. Web pages are often very poor at describing the options and making it clear to users where they should go to achieve the desired result.
Planning Effective Web Pages

Screen Resolution And Page Design

Your office mate has their monitor set to 800 x 600 pixels, while yours is set to 1024 x 768 pixels. You have more pixels, right? So how come everything looks smaller on your screen? It's because the pixels on your screen are smaller, so more of them fit into the same space. While this concept sounds like a great idea, it can affect the overall usability and accessibility of your web site.

The term **Screen Resolution** refers to the number of individual pixels that fit within a given space. When we are discussing an 800 x 600 resolution, the number 800 refers to the number of pixels that the monitor can display horizontally, while the number 600 refers to the vertical limit.

Monitor size and optimal screen resolution are closely linked. As you increase the resolution, the screen elements appear smaller. In fact, the information contained on a 15-inch screen set to 1024 x 768 may be so small that it is virtually unreadable. But the same information displayed at that resolution on a 17 or 21-inch monitor would look fine.

Ideally, your site should be completely device and browser-independent, but that's an almost impossible standard. The next best strategy is to design a site that looks good and performs well for the vast majority of your visitors.

Avoid informing visitors that your site is “best viewed at” a certain resolution or with a certain browsers. To seasoned web users, this less-than-helpful hint screams that the site is poorly planned and designed. Fortunately, it isn't hard to design and test a good looking site. You just have to take the time to do so.

Many web designers in the public sector use large monitors and run them at the highest resolution possible. A 2004 survey reflected that about 24% of people use 800 x 600 as a screen resolution while 72% use 1024 x 768 or higher. In the Coast Guard, Districts may vary as to the default setting for their computers and users have the ability to change their resolution any time they like.

As a general rule, you should design all of your pages to be optimally viewed on computers set to 800 x 600. Now remember that someone viewing the page at a higher resolution may see a lot of empty space (depending on how it is designed).

What happens when a designer considers how the page will look to all visitors? The usability level of the site increases, as does visitor satisfaction - and hopefully repeat visitors. You don't have to design an ugly site geared towards the lowest common denominator. Just put some thought into how the site looks in configurations other than your own.
Overview Of The FrontPage Window

Microsoft FrontPage 2003 provides web designers and developers with a set of tools to enable the creation of web sites quickly and easily. FrontPage 2003 centralizes all of the design, coding and publishing functions to provide a total web creation and management solution with the flexibility to match your design and coding skills. With FrontPage’s tools, layout and graphics features, you will be able to quickly design professional looking web sites.

Terminology Check

**Views Bar**
Displays web content in different views.

**Web Page Tabs**
Displays the open web pages name. The active web page appears in white.

**Folder List**
Displays all files associated with the current web site. This view can be toggled on and off as well as switching it to a page navigation view.

**Task Pane**
Contains useful commands to run the most common tasks.

**Tool Bar**
A set of buttons, usually with an icon of some sort that are used to activate a program's function.

**Status Bar**
The area at the bottom of FrontPage that displays information about the currently selected command or about an operation in progress.
Using Toolbars

Microsoft FrontPage has 14 different toolbars that you can use. **Toolbars** contain buttons that allow you to complete a command by clicking on a button instead of having to navigate through the menus. Toolbars can easily be activated and deactivated so you can quickly access shortcuts to commands that you use most often.

**STEPS:** To activate or deactivate a toolbar:

1. Click on **VIEW ⇒ TOOLBARS**.
2. Click on the toolbar that you want to activate or deactivate.

**Alternate Method:**

1. Right click on any toolbar.
2. Click on the toolbar that you want to activate or deactivate.

Toolbars that have a checkmark next to their name are already showing on your screen.

**Moving Toolbars**

Toolbars can be rearranged on your screen. They can be “docked” or they can “float”. Docked toolbars look like they are integrated with the screen, usually at the top or bottom of the window. Floating toolbars appear in the middle of your screen.

**STEPS:** To move a toolbar:

1. Move the mouse pointer to the dotted **VERTICAL BAR** that appears on the far left of the toolbar you want to move.
2. Drag and drop the toolbar to any position you like on the screen.

**Docking Toolbars**

If your toolbar is floating on your screen and you want to integrate it with the rest of the window, double click on the toolbar’s Title Bar.

Double click on the Title Bar to dock the toolbar in the window.
Using Shortcut Keys

*Shortcut Keys* help provide an easier and usually quicker method of navigating and using FrontPage as well as most software programs. Shortcut keys are commonly accessed by using the Alt, Ctrl and/or Shift in conjunction with a single letter. For example pressing \[CTRL\] + [S] would perform the save operation. As you begin to work with shortcut keys, you will notice that several applications share the same shortcut keys. In this manual, a combination keystroke will be presented as: Press [CTRL] + [N].

A list of the common shortcut keys is printed in the back of this manual in Appendix A. You can also check for common shortcut keys in the menus. For example, pull down the Edit menu, and you will see that some common commands are accompanied by their Shortcut Keys on the right, as shown below.

### Time Savers

The Standard and Formatting toolbars are relatively consistent across all of the Office programs. Getting familiar with these toolbars is time well spent. If you do not see both toolbars, they may be positioned side by side. If the toolbars are stacked together, a TOOLBAR OPTIONS button appears at the end of the toolbars. You can click on this button to expand the toolbar to display the hidden buttons on that toolbar, as shown below. This is a feature in Office 2003 that is designed to give you more screen space. To turn this feature off select TOOLS ⇒ CUSTOMIZE, click on the Options tab and deselect Standard And Formatting Toolbars Share One Row.
Getting Help

You may have forgotten certain items or want to explore new features. The built-in FrontPage Help will be very useful. When you access the Help files, the details and execution of every task is just a mouse click away. You can search for topics, move forward and back through topics and automatically search Microsoft’s online help files.

Getting Help from the Microsoft Office FrontPage Help

1. You can type specific words or phrases in the Search for box to return a list of possible answers.

2. You can also click on the Table of Contents link to browse for the help you need.

3. If you are connected to the Internet, you can access the Microsoft Office Online web site, which offers online help documents, templates, add-ins and online training.

Type a Question for Help Box

You can type questions in this box to quickly find the answers you need. A very specific search with 2-7 words will return the most accurate results. The results of your search are returned in the Search Results Task Pane in order of relevance. To return to the Search window, click on the BACK arrow at the top of the task pane.

Help from the Office Assistant

The Office Assistant appears on screen providing Help topics and tips to help you accomplish your tasks. This is no longer the default help option. If you want to use the Office assistant, you will need to deliberately activate it by clicking on HELP ⇒ SHOW THE OFFICE ASSISTANT.

▶ STEPS: To access Microsoft FrontPage Help:

1. Select HELP ⇒ MICROSOFT FRONTPAGE HELP.
2. In the task pane that appears, type in the topic that you would like help on in the Search For field and then click on the ARROW button or press [ENTER].
Creating A New Web Site

In this section, you will learn more about:

- Creating A FrontPage Web Site
- Hide And Display The Folder List
- Managing Files And Folders
- Creating Web Pages Using Templates
- Creating Blank Web Pages
- Saving Pages
- Changing Page Views
- Previewing Web Pages
Creating A FrontPage Web Site

Not only is FrontPage a web site design tool, but it has another major role that's important to remember, FrontPage is also a web site management tool.

With FrontPage you can add, rename, delete or move around files (without doing it in Microsoft Windows Explorer); find problems by using special reports, like the broken hyperlinks report and publish your web site.

What is a FrontPage Web Site?

Unlike other web sites, a FrontPage web site contains FrontPage-specific information in addition to web pages, graphics, documents and multimedia files. These FrontPage files are called Metadata. FrontPage metadata is stored in hidden folders and files that support FrontPage-specific functionality. They are hidden to prevent them from accidentally being deleted, changed or moved. This metadata is what FrontPage uses to help you manage your site.

► STEPS: To create a new FrontPage web site:

1. Click on FILE ➔ NEW.
2. In the NEW task pane, click on One Page Web Site.
3. In the Web Site Templates dialog box, under the General tab, select the web site template that you want to use.
4. Click on OK.

► STEPS: To open an existing web site:

1. Click on FILE ➔ OPEN SITE.
2. In the Open Site dialog box, browse to and then select the folder that contains your web site.
3. Click on OPEN. Note: If the web site that you are opening is not a FrontPage site, you will be prompted to add FrontPage information to the folder.

Normally, you can simply close FrontPage with your web site still open. The next time you open FrontPage, it will reopen the same web site. Occasionally, you may want to close the web site that you are working on and open another one.

► STEPS: To close a web site, click on FILE ➔ CLOSE WEB SITE.

Caution

Once a FrontPage site has been created, you MUST perform all of your file management activities from within FrontPage. Do not use Windows Explorer to add, delete or rename files.
Hide And Display The Folder List

The **Folder List** will display all the web pages, images, folders and other items in your web site. Because the folder list can take up quite a bit of space on your screen, Microsoft has made it so that you can easily display or hide the Folder List.

![Folder List and Toggle Button](image)

**STEPS:** To toggle the Folder list on or off:

1. Click on the **TOGGLE PANE** drop-down arrow on the **Standard toolbar**, and select **FOLDER LIST**.
2. The same action will toggle the folder list off.

**Bright Idea**

You can make your web site easier to manage and navigate by creating lots of folders. Create a folder for every group of documents you’ll have at your site. Try to keep all of your images in a single folder. Label the folders and directories in a way that makes sense. Use sub-folders to further organize your content, if it makes sense.

FrontPage keeps track of where every file is so if you move a file from one folder to another, it will make sure the paths are correct.
Managing Files And Folders

Once you have created a FrontPage web site, you will perform all of your file management tasks from within FrontPage.

Open and Close Web Pages

► STEPS: To open a web page for editing, double click on the web page in the Folder List.

Creating Web Folders

► STEPS: To create a new web folder:

1. Open the Folder List.
2. Right click on the folder where you want to create a subfolder under.
3. Select NEW ⇒ FOLDER from the shortcut menu that appears.
4. Name the folder using the rules shown in the Caution note on page 21.

Renaming Files and Folders

► STEPS: To rename a file or folder, right click on the item and choose RENAME from the shortcut menu.

Deleting Files and Folders

► STEPS: To delete a file or folder, single click on the item to select it and press [DELETE] on your keyboard.
Creating Web Pages Using Templates

A page template is a pre-designed page that can contain page settings, formatting, and page elements. Microsoft FrontPage provides several default page templates, or you can create your own so that you can create pages for your web site quickly and consistently. Templates are very useful in a multiple-author environment because they help authors create pages the same way. For example, if all your pages always have a unit logo and description at the top of the page, you can create a template with those elements. You could then use your template when you create a new page, and the logo and description will automatically display on the page.

**STEPS:** To create a page using an existing page template:

1. Click on FILE ⇒ NEW.
2. In the New Page task pane, under New page, click on MORE PAGE TEMPLATES.
3. In the Page Templates dialog box, select the template that you want.
4. Click on OK.

**STEPS:** To create a new template:

1. Create a new web page as outlined in the next section.
2. Click on FILE ⇒ SAVE AS.
3. Name the web page as desired.
4. Click on the Save as Type drop-down box and select FrontPage Template (*.tem).
5. Click on SAVE.
Creating Blank Web Pages

While pre-designed templates may be an easy way to get started, you may not find a template that meets your needs or design specification. You can easily create a blank web page and fill in the details as you see fit.

**STEPS:**

To create a blank web page:

1. Click on **FILE ➔ NEW**.
2. In the **New** task pane, click on **BLANK PAGE**.

**Alternate Method:**

1. Click on the **CREATE A NEW NORMAL PAGE** button on the **Standard** toolbar.

**Bright Idea**

In FrontPage, although you can use images and files located on your hard drive or network folder, you will need to import files and folders into your web site to insure that all necessary files will be uploaded to the web server when you publish the site. From the **Folder List**, select the folder that you want the imported files to be stored in. Click on **FILE ➔ IMPORT**. Click on **ADD FILE OR ADD FOLDER** button. Locate and select the file that you want to import, and then click on **OPEN**. You can continue to click on the **ADD FILE** or **ADD FOLDER** to populate the **Import** dialog box. Once complete, click on **OK**.
Saving Pages

Before you can preview your web page, you will need to save it. This needs to be done for newly created pages and for pages that have been edited. How you save it will depend on where the page was originally opened from.

▶ STEPS: To save a web page to the current web site:

- For pages that have not yet been saved:
  1. Click on the SAVE button.
  2. Locate and double click on the folder where you want to save the page.
  3. In the File Name box, type the file name of the page and then click on SAVE.

- For pages that have been opened from the current website:
  1. Click on the SAVE button.

- For pages opened from a location outside the current website (This action imports the web page into your site.):
  1. Click on FILE ➔ SAVE AS.
  2. Locate and double click the folder where you want to save the page.
  3. In the File Name box, type the file name of the page and then click on SAVE.

Caution

Browsers and servers have their own set of rules when they try to read the files you create for the web. Follow these guidelines to prevent possible problems with your web pages.

1. Generally, your home page must be named home.htm or index.htm.
2. Never use spaces within, before or after the name of ANY file that is destined to go on a web server. This includes Adobe Acrobat files, Microsoft Word and Excel documents, etc.
3. Never use unusual characters within a file name. Avoid punctuation marks (other than period, hyphen or underscore), accented vowels and other special characters.
4. Keep your file names short but meaningful.
5. As a general rule, for simple web pages created in FrontPage, all web page files must end in .htm, .html or .asp
6. All graphic files must end in .gif, .jpg, .jpeg or .png
7. Some web servers are case sensitive (most CG web servers are not, however). That is, the file home.htm is regarded as a different file than Home.htm. If you use upper case, you need to be consistent in all your links to that file. The safest course is to keep everything in lower case.
Changing Page Views

There are four different ways you can look at the content on your web page as you create it. By using different views of your pages as you design, publish and manage your site, you can find and solve site problems and make the whole web creation, revision and publication process more effective. To work with your web page in one of the Page views described below, click on the view that you want to use at the bottom of the document window.

Design View

You can design and edit web pages in the default Design view. This view provides you with a “What You See Is What You Get” (WYSIWIG) view. This view allows you to view a page as it will appear in the final product and to directly edit the text, graphics, and other elements within that page.

Code View

You can view, write and edit the HTML tags yourself. With the optimized Code view in FrontPage, you can create “clean” HTML, and it is easier for you to remove any FrontPage code you do not want.

Split View

You can review and edit web page content in a Split screen format that offers you simultaneous access to both the Code and Design views.

Preview View

You can see approximately how the page will look in the web browser without having to save your page. Use this view to check small changes before you commit to them. Please note that not all web page functionality may be viewable from the Preview view. See the next section to learn how to get an accurate view of your pages.
Previewing Web Pages

While designing a web page, it's often difficult to know what portion of the page will be visible to site visitors who have different screen resolutions or what the page will look like in different web browsers. Fortunately, FrontPage 2003 has two different preview options for your web page.

*Preview in Browser* – This feature lets you open the web page that you are working on in the browser of your choice directly from FrontPage. This is the most accurate way to preview your web page. Before you can preview a web page in a browser, you must save it first.

*Preview View* - By using the Preview view, you can quickly determine whether the page you are designing will appear as expected in a web browser. Because you can use the Preview view without having to save your web page, the Preview view is often more useful for viewing design ideas that you're not yet ready to commit to.

**STEPS:** To view a page in the Preview view, click on the Preview tab on the bottom of the screen.

**STEPS:** To preview a web page in a browser:

1. Click on FILE ➔ PREVIEW IN BROWSER.
2. Select the resolution and web browser you want to use to preview your web page.

Alternate Method

1. Click on the drop-down arrow on the PREVIEW button on the Standard Toolbar to quickly display a web page in a web browser.

**Bright Idea**

You can either save the page manually each time you want to preview the page, or you can have the pages automatically save each time you preview the page. Click on FILE ➔ PREVIEW IN BROWSER ➔ EDIT BROWSER LIST. Select the **Automatically Save Page Before Previewing** check box.
Managing Web Pages

In this section, you will learn more about:

- Changing The Page Title
- Formatting Text
- Using The Format Painter
- Creating Numbered And Bulleted Lists
- Creating Definition Lists
- Changing Background Colors
- Adding Background Images
- Inserting Horizontal Lines
Changing The Page Title

The *Page Title* is the name that appears in the title bar of most web browsers. The title can be different from the file name. For example, the title of your home page could be “My home page” even though the file name is “Default.htm”.

**STEPS:** To change your web page title:

1. Click on **FILE ➔ PROPERTIES**.
2. In the **Title** box, type the title for the web page.
3. Click on **OK**.

**Bright Idea**

When a visitor marks your web page as a *Favorite*, the page title becomes the default bookmark name. Take some time to devise good titles for your pages. Titles should be short, concise and to the point. Think of the page title as the summary for your page. Also, imagine how you would like your page to appear in someone’s Favorites list. For example, instead of using “*What You Need To Know About Life Vests For Children*”, try titling your page “*Life Vests For Children - What You Need To Know*”
Formatting Text

You can format text in FrontPage using the same methods you would in any other program. You can change the font, size, style, color, spacing and add effects such as underlining. You can also control spacing and indentation, add bullets, numbers, and set alignment.

You can apply formatting to either selected words, or an entire paragraph. A general rule is that you can apply font properties such as font, size, color, highlighting and effects to selected text, and paragraph properties such as alignment, bullets, numbering, shading and borders to entire paragraphs. For example, you can italicize a single word in a paragraph, but if you try to align the word to the right, the entire paragraph will align right as well.

You can apply the most common formatting from the Formatting Toolbar.

Character Formatting

**STEPS:** To change character formatting:

1. Select the text that you want to change.
2. Use the **Font Type** drop-down box to select a font style.
3. Change the font size from the **Font Size** drop-down box.
4. Click on the **BOLD**, **ITALIC** or **UNDERLINE** buttons, if desired.
5. Click on these buttons again to turn that formatting off.
6. To change the font color, click on the **FONT COLOR** drop-down arrow and select the color you want from the color palette.

**Bright Idea**

Use the following guidelines for your most common formatting actions:

- When you want to apply formatting to text that has already been typed, you MUST select that text first.
- To identify a formatting button on the toolbar, pause your mouse over the button and you will see a **ToolTip** that will help to explain that button.
- Many of the formatting options have keyboard shortcuts. Use these to turn on the formatting you want to use before you type text. For example if you want a group of words to be Italic, press **[CTRL] + [I]** to turn on the italics, type the text, then press **[CTRL] + [I]** again to turn off the italics.
Formatting Text

Using the Font Dialog Box

You can access even more formatting options by opening the Font dialog box. Some available options in this dialog box include changing character spacing, superscript, subscript, small caps and strikethrough.

▶ STEPS: To use the Font dialog box to format text:

1. Select the text that you want to change.
2. Click on FORMAT ⇒ FONT.

3. Select the desired formatting for the text.
4. Watch the Preview box at the bottom of the dialog box to see what your changes will look like.
5. Click on OK.

Time Savers

You can quickly increase or decrease the font size of text by selecting the text you want to resize and clicking on INCREASE FONT SIZE or DECREASE FONT SIZE buttons on the Formatting toolbar.

Note: The smallest font you can get by clicking Decrease Font Size is 8 points, and the largest font you can get by clicking Increase Font Size is 36 points.
Formatting Text

Basic Paragraph Formatting

Paragraphs are defined by *Hard Returns*. You create a paragraph every time you press the [ENTER] key on your keyboard. When you apply formatting to a paragraph, it is not necessary to select the paragraph first. Simply click the mouse in any part of the paragraph, then apply the paragraph formatting.

Paragraph formatting such as centering, indentation, spacing, bullets and tab stops are applied to the whole paragraph rather than individual characters. For example, you cannot center a word within a paragraph of words without centering the whole paragraph. This is different from character formatting in which you can format a single letter if you choose.

**STEPS:** To apply paragraph formatting to a paragraph:

1. Place the cursor anywhere in the desired paragraph. If you wish to apply the formatting to multiple paragraphs, you must first select all the paragraphs.
2. Select **LEFT ALIGN**, **CENTER ALIGN**, **RIGHT ALIGN** or **JUSTIFY** from the **Formatting** toolbar.
3. To adjust the line spacing, click on the drop-down arrow on the **LINE SPACING** button and select a desired spacing.

Additional Paragraph Formatting

You can access even more paragraph formatting options by opening the **Paragraph** dialog box. Some available options in this dialog box include space before and after the paragraph, indenting and line spacing.

**STEPS:** To use the Paragraph dialog box to format text:

1. Select the paragraph(s) that you want to change.
2. Click on **FORMAT** ➔ **PARAGRAPH**.
3. Select the desired formatting for the paragraph.
4. Watch the **Preview** box at the bottom of the dialog box to see what your changes will look like.
5. Click on **OK**.
Using The Format Painter

Microsoft Office has a feature that allows you to copy the formats of characters or paragraphs and apply these formats to another location. This feature is called the Format Painter. This feature is not only a time saver, but it will help add a more consistent look throughout your web pages because you will not have to remember font type, size, spacing, etc.

Let’s say that you have changed your page headers to Bold, Underline, 18 point and Arial and you want to make sure all of your page headers are the same. You can easily use the format painter to accomplish this.

**STEPS:** To copy formatting from one place on your document to another:

1. Select the word or paragraph that already has the character formats that you want to copy.
2. Click on the FORMAT PAINTER button.
   
   **Note:** If you want to copy formatting from one page to another, you must double click on the FORMAT PAINTER button.
3. To format a single word, click once on the word that should receive the copied format. To format a paragraph, drag the paintbrush over the paragraph that should receive the copied format.

---

**Time Savers**

If you only click on the FORMAT PAINTER once, it is good for one “painting”. If you have a need to apply the formatting to several places in the document, you can Double Click on the FORMAT PAINTER button. This will keep the format painter “locked” until you click on the button again or press the [ESC] key.
Creating Numbered And Bulleted Lists

You can separate items in a list by beginning each item with a bullet or number. Bulleted lists are useful for items in no particular order, for example a list of resources and services. Numbered lists are useful for items in a specific order. You can also create an attractive list on a web page that uses small graphics or icons as bullets.

► STEPS: To create a numbered or bulleted list:

1. Select the text you want to display as a bulleted or numbered list.
2. Click on one of the following buttons on the Formatting toolbar:
   - BULLETS
   - NUMBERING

Creating a List with Picture Bullets

The Bullets and Numbering dialog box gives you options on the styles of bullets and numbering that are available for your list. In this dialog box, you can also specify graphic images for your bullets.

► STEPS: To modify a bulleted list with image bullets:

1. Select the text that you want to modify.
2. Click on FORMAT ⇒ BULLETS AND NUMBERING.
3. In the Bullets and Numbering dialog box, click on the appropriate tab and select a bullet or number style. To add graphic images, such as bullets, click on the Picture Bullets tab.
4. Click on SPECIFY PICTURE OPTION click the BROWSE button.
5. Locate the image you want to use, then click on the OPEN button.
6. Click on OK.
Creating Definition Lists

A Definition List is created to define special phases, terms or words. The descriptions are automatically indented for each term. The code actually separates the text into two different parts called Definition Term and Definition. Web browsers recognize this code and indent and space the text accordingly.

**Steps:**

1. Position your cursor where you want the first item in the list to appear.
2. Click on the Style drop-down arrow on the Formatting Toolbar, then click on DEFINED TERM.
3. Type the first term in the list and then press [ENTER].
4. Type the definition of the term and then press [ENTER].
5. Repeat steps 3 through 4 for each term and definition.
6. Press [ENTER] twice when you have finished.

**Bright Idea**

There may be times when you need to start a separate line for your definition. Normally, when you press [ENTER] on your keyboard, a new definition term will be created. To work around this, press [SHIFT] + [ENTER].
Changing Background Colors

You can change the background color of a web page to make it more attractive and presentable. Make sure the selected background color works well with the text color. For example, yellow text on a white background is difficult to read.

**STEPS:**

To change the background color of a web page:

1. Click anywhere on the web page for which you want to change the background color.
2. Click on **FORMAT ⇒ BACKGROUND**.
3. Under the **Colors** area, click on the **BACKGROUND** drop-down arrow and select the color that you want.
4. Click on **OK**.

**Bright Idea**

Have you ever gone to a site that takes forever to download because the amount or size of the graphics or the amount of text? When you open a page in the FrontPage, the status bar will display the estimated time it will take for that page to download at a given connection speed.

To test this feature, open a page and switch to the design or **Split** view. Click on the **ESTIMATED TIME TO DOWNLOAD** box in the **Status Bar**. A pop-up menu will appear. Choose from the listing of connection speeds.

Now when you are designing your page you will know how fast it will load at that speed. When you are finished, you can choose other speeds to see the differences.
Adding Background Images

You can easily set a background picture for a page in lieu of a background color. You can use pictures from your file system or the Microsoft Clip Art Gallery.

All browsers can display background images. These images are small .gif or .jpg images that the browser “tiles” (an image that is repeated over and over) to fill the window. Each single tile can be as small as you like but due to the tiling, the computer requires more processing time to fill the screen. This will make screen updates painfully obvious. Even a small size image that is tiled on the background can cause the page to load very slowly. Likewise, if the background image is a single large file, it will take the page a significant amount of time to download. Experiment with different sized images to find the best compromise between downloading time and screen redraw. See Page 44 to learn about optimizing images for web use.

Remember that text will usually have to go over your background image. If the background has too strong of a pattern, it will make the text hard to read. You can put dark text on a light background and light type on a dark background without too much trouble. However, when you use a mid tone background, you may stand more chance of compromising visibility.

▶ STEPS:  To add a background image to your web page:

1. Click anywhere on the web page that you want to add a background image.
2. Click on **FORMAT ⇒ BACKGROUND**.
3. Under the **Formatting** area, select the **Background Picture** check box, and then click on the **BROWSE** button.
4. Locate the image you want to use and click on the **OPEN** button.
5. Click on **OK**.

**Bright Idea**

*Watermarks* are non-scrolling pictures that appear as your background. To enable this effect, check the **MAKE IT A WATERMARK** check box in the **Page Properties** dialog box.
Inserting Horizontal Lines

*Horizontal Lines* (also called Horizontal Rules) separate text, paragraphs or other components on a web page. By dividing your web page into separate sections, it may be easier to read and navigate. Microsoft FrontPage makes it easy to modify Horizontal Lines to fit your page’s layout and color scheme.

**STEPS:** To create a Horizontal Line:

1. Place the cursor where you want to insert a Horizontal Line.
2. Click on **INSERT ➔ HORIZONTAL LINE**.
3. To modify the appearance of the horizontal line, double-click on the horizontal line, then do one or more of the following:
   - To increase or decrease the width of the line, enter a different pixel or percentage value in the **Width** box, then select **Percent of window** or **Pixels**, depending on the type of value you entered.
   - To increase or decrease the height of the line, enter a different pixel value in the **Height** box.
   - To align the line to the left, center, or right on the page, under **Alignment**, select the alignment option you want.
   - To add color to the line, select a color in the **Color** list.
   - If you want the line to appear solid, select the **Solid line (no shading)** check box.
Hyperlinks

In this section, you will learn more about:

- Creating Bookmarks
- Inserting Hyperlinks
- Changing Hyperlink Color
Creating Bookmarks

A **Bookmark** identifies the location that you want visitors to be able to quickly display. To use bookmarks, you create a hyperlink that allows visitors to navigate directly to that bookmark. You must create a bookmark **before** you can create a link to that particular web page area.

You can bookmark text, a graphic image or a spot on a web page. If a location (rather than text) is bookmarked, the bookmark is indicated by 📌. If text is bookmarked, the text is displayed with a dashed underline.

**Steps:**

1. Select the text, image or click in the location that you want to create the bookmark.
2. Click on **Insert ➔ Bookmark.**
3. In the **Bookmark Name** box, type the name for the bookmark.
   - **Important!** Do not put spaces in the bookmark name.
4. Click on **OK.**
Inserting Hyperlinks

A **Hyperlink** is usually used to link one web page to another. When a visitor clicks the hyperlink, the destination page is displayed. Although linking to a web page is the most common use for hyperlinks, you can also create links to e-mail addresses, multi-media files and files from different applications.

When you rename a file (web page, picture, etc) in your web site, FrontPage checks to see whether there are any hyperlinks to the file. If there are, FrontPage updates the hyperlinks with the new file name.

Always test your hyperlinks! If your web site contains broken links, visitors will get an error message when they click on it. Often, this is very easy to fix. Frequently test your links that point to another web site on the internet or intranet. You never know when the page will move or change names and/or file locations.

Hyperlinks to Existing Pages or Files

**STEPS:** To create a hyperlink to an existing page or file:

1. Select the text or the picture that you want to use as the hyperlink.
2. On the **Standard** toolbar, click on the **INSERT HYPERLINK** button.
3. Under **Link to**, click on **Existing File or Web Page**.
4. Select the page or file you want to use as a destination.

**Bright Idea**

By default, FrontPage will create **Relative Hyperlinks**. This means the link is relative to the current page position in the web site. You will see links as “calendar.htm” or “..\schedule\calendar.htm. The "../" in the means "go one level up" from the folder where the current page is being viewed. Links to external web pages will display as **Absolute Hyperlinks**. An absolute link is the full URL path to the target page such as “http://cgweb.pacarea.uscg.mil/”.
Inserting Hyperlinks

Inserting Hyperlinks to Bookmarks

► STEPS: To create hyperlinks to existing bookmarks:

1. Select the text or picture to become the hyperlink.
2. On the Standard toolbar, click on the INSERT HYPERLINK button.
3. Under Link to, click on EXISTING FILE OR WEB PAGE.
4. Select the page that contains the bookmark.
5. Click on the BOOKMARK button.
6. Under Select A Place In This Document, select the bookmark you want to use as the destination, then click on OK.

Inserting Hyperlinks to Other Web Sites

► STEPS: To create hyperlinks to other web sites:

1. Select the text or picture to become the hyperlink.
2. On the Standard toolbar, click on the INSERT HYPERLINK button.
3. Under Link to, click on EXISTING FILE OR WEB PAGE.
4. To the right of the Look in box, click the BROWSE THE WEB button.
5. In your web browser, navigate to the page that you want to link to, then press [ALT] + [TAB] to switch back to FrontPage. The location of the page you visited will be added in the Address box.
6. Click on OK.

Alternate Method:

1. Type or paste the desired URL into the Address box.

Inserting E-Mail Hyperlinks

► STEPS: To create a hyperlink that generates an e-mail message:

1. Select the text to become the hyperlink.
2. On the Standard toolbar, click on the INSERT HYPERLINK button.
3. Under Link to, click on E-MAIL ADDRESS.
4. Type the e-mail address you want in the E-mail address box, or select an e-mail address in the Recently used e-mail addresses box.
5. (Optional) In the Subject box, type the subject of the e-mail message.
6. Click on OK.

Bright Idea

There may be times when you want the destination of a hyperlink to open in a new window. This is useful if you think that the link will cause a visitor to lose your site. From the Insert Hyperlink dialog box click on the TARGET FRAME button. In the Target Frame dialog box, select NEW WINDOW, then click on OK.
Changing Hyperlink Colors

Hyperlinks will typically follow the default formatting options set by a visitor’s browser. Normally, this is set so that the hyperlink appears blue and will turn purple once visited. You may find that this conflicts with the font style or color scheme of your web page, especially if your background is a dark color.

Changing the Default Hyperlink Color

► STEPS: To change the hyperlink colors for a web page:

1. Right click the page, then select PAGE PROPERTIES from the shortcut menu.
2. Click on the Formatting tab.
3. Under Colors, in the Hyperlink, Visited hyperlink and Active hyperlink boxes, select the colors you want to use.
4. Click on OK.

Adding Effects to your Hyperlinks

You can add effects to hyperlinks so that when a visitor positions their pointer over the hyperlink, its font changes. For example, you can set the hyperlink to change from a green font to a yellow font. Note that when you set font effects, you set them for all hyperlinks on the page, rather than for individual hyperlinks.

► STEPS: To create hyperlink effects:

1. Right click the page, then select PAGE PROPERTIES from the shortcut menu.
2. Click on the Advanced tab.
3. Under Styles, select the ENABLE HYPERLINK ROLLOVER EFFECTS check box.
4. Click on ROLLOVER STYLE and set the rollover properties for hyperlinks on the current page.
5. Click on OK twice.
Graphic Images

In this section, you will learn more about:

- Optimizing Images For Web Use
- Inserting Graphic Images
- Inserting Clip Art
- Utilizing The Picture Toolbar
- Resizing And Aligning Images
- Adjusting Graphic Image Layout
- Adding Text Alternatives To Images
- Creating An Image Map
- Creating Photo Galleries
- Inserting Video Clips
Optimizing Images For Web Use

Optimizing images for the web is a tricky business. Because you have to get the right balance between file size and picture quality. It is an essential step though. Look at any webpage and you will see that most of its load time comes from images. Your web site will be needlessly slow if you don't optimize the size of these images.

There are several key areas that need to be addressed when adding graphic images to your web site.

Choose the Best File Format

One of the more common mistakes which lead to large image sizes is from using the wrong file format. The simple rule to follow is this:

- .gif files should be used for the bulk of your images. Simple line drawings, shapes, small icons, etc all appear great when saved as .gif files.
- .jpg files (.jpeg) should be used for photographs
- Never use bitmaps for anything on your web site.

The best way to choose the format for a graphic if you can't make up your mind is to experiment and save it as both a .gif and a .jpg then compare their sizes and image quality.

Crop Unnecessary Image Area

Use the Crop tool in your graphic image editing program (or FrontPage) to cut out everything but the essential parts of the image. Cropping allows the important part of the image to be seen but it takes up less space on your page.

Another way of achieving this is to use a Thumbnail image to link to the main image. This means you make a smaller (in physical size and file size) image which links to the full size version of the picture.

Scale Back the Image Resolution

What does Image Resolution mean? Image Resolution refers to the number of pixels in an image. Resolution is sometimes identified by the width and height of the image as well as the total number of pixels in the image. For example, an image that is 2048 pixels wide and 1536 pixels high (2048 x 1536) contains 3,145,728 pixels (or 3.1 Mega pixels). You could call it a 2048 x 1536 or a 3.1 Mega pixel image.
Inserting Graphic Images

One of the simplest ways to improve the appeal of your site is to add graphics to it. Graphics should convey information to visitors, as well as make your site more pleasing to the eye. Keep in mind that too many graphics can overshadow your content, not to mention slow down the loading process of your pages.

**STEPS:**

To insert a graphic image:

1. Click where you want to insert an image.
2. Click on **INSERT** ➔ **PICTURE** ➔ **FROM FILE**.
3. In the **Look In** box, locate the folder where the image is stored and select the image that you want to insert.
4. Click on **INSERT**. This will insert the graphic into the web page. You now have to save the graphic image into the web site.
5. Save the web page by clicking on the **SAVE** button on the **Standard** toolbar.
6. In the **Save Embedded Files** dialog box, rename the image, if desired, by clicking on **RENAME**, specify the folder location by clicking on **CHANGE FOLDER** or overwrite an existing image by clicking on **SET ACTION**.
7. Click on **OK**.
Inserting Clip Art

You can include *Clip Art* images in a web page to enhance the page by depicting an idea that may be difficult to describe or by making the page more visually appealing.

To find specific Clip Art, you can search for images based on keywords. Keywords related to the selected Clip Art image appear as a ScreenTip when you hover over the Clip Art image. Available Clip Art is divided into several collections such as Animals, People and Sports. You can also choose to only specific categories if desired.

▶ STEPS: To insert a Clip Art image into a web page:

1. Position the cursor point where you want the Clip Art image to appear.
2. Click on `INSERT` ➤ `PICTURE` ➤ `CLIP ART`. This will open the Clip Art Task Pane.
3. In the `Search for` box, type a word or phrase related to the clip you want.
4. Click on the `GO` button. You can narrow down the search results by selecting options for the `Search In` and `Results Should Be` drop-down menus.
5. To browse for Clip Art, click on the `Search In` drop-down and select a collection.
6. Once you find the Clip Art that you want, simply click on it to insert it.

*Bright Idea*

If you have an internet connection (as most Coast Guard workstations do), the *Clip Art* task pane will automatically connect to the Microsoft Office online clip art gallery and allow you to instantly download those images. Image thumbnails that have an internet globe on them are the Microsoft online images.
Utilizing The Pictures Toolbar

An extremely useful feature of FrontPage 2003 is the ability to modify graphic images within the program itself. Often, this will eliminate the need for an additional graphic image editing program. Most tools that you will need are on the **Pictures** toolbar. To view the **Pictures** toolbar, right click on any image and choose **SHOW PICTURES TOOLBAR**.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Insert</strong></td>
<td>One of the ways to insert an image directly into a page is to click on the <strong>INSERT</strong> button and navigate to the desired image. You can also insert images from the <strong>Clip Art Task Pane</strong>.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td>Text can be placed directly on a .gif image. This is useful if you want to create a button, add a caption to an image, etc. Select an image, click on the <strong>TEXT</strong> button on the <strong>Pictures</strong> toolbar and type the desired word or phrase. You can format the text in the usual manner. You can position the text box by clicking and dragging the text box with your mouse. If you want to place text on a .jpg image, you will have to convert it to a .gif first. You can do this directly in FrontPage by right-clicking an image and selecting <strong>Convert Picture</strong>. When the dialog box opens, select GIF and then click on <strong>OK</strong>. Note that the quality of a JPEG image will be changed, sometimes considerably, after it is converted to a GIF.</td>
</tr>
<tr>
<td><strong>AutoThumbnail</strong></td>
<td>This feature allows you to quickly create thumbnails of a larger images. To create a thumbnail, insert an image into a page, select it and click on the <strong>AUTO THUMBNAIL</strong> button. The image will disappear and a thumbnail version appears in its place. When the page is saved, you will be prompted to save the embedded file. The thumbnail automatically becomes a hyperlink to its corresponding full-sized image. When a site visitor clicks on the thumbnail, the image is displayed in a browser. (See page 54 for more details.)</td>
</tr>
<tr>
<td><strong>Position Absolutely,</strong></td>
<td>The <strong>Position Absolutely</strong> property allows images to be layered on your web page. To apply absolute position to a graphic image, select the image, click on the <strong>POSITION ABSOLUTELY</strong> button on the toolbar and click and drag the image with your mouse to position it. To set positioned images in front or in back of other page content or each other, use the <strong>BRING FORWARD</strong> and <strong>SEND BACKWARD</strong> buttons.</td>
</tr>
</tbody>
</table>
Utilizing The Picture Toolbar

**Rotate or Flip**  
Use these icons to rotate an image 90 degrees counterclockwise or clockwise. Images can also be mirrored (flipped right to left) and inverted (turns a graphic upside down by flipping it from top to bottom).

**More or Less Contrast, More or Less Brightness**  
The Brightness and Contrast tools are particularly useful with images such as digital photos. By increasing contrast, light colors become lighter and dark colors become darker. The opposite happens when you decrease contrast. When you increase brightness, every color in an image becomes whiter. All colors become blacker when brightness is decreased.

**Crop**  
All images, even those with a transparent background, are square or rectangular shaped. Use the Crop tool to trim away unwanted areas. After selecting the image, click once on the CROP button. A rectangular shape with handles appears and you simply click and drag one handle at a time to resize the shape. When you positioned the crop box where you want, click on the crop tool again to remove the excess area of the image outside the crop lines or press [ENTER] on your keyboard. See page 51 for more information on cropping.

**Line Style**  
If you created a line in FrontPage using the Drawing toolbar, select it and use this icon to change its point size and style.

**Format picture**  
A drawing created within FrontPage with tools on the Drawing toolbar can be changed by selecting it, then enabling the Pictures toolbar which in this case will not appear automatically when you select the drawing. When the image is selected the Format AutoShape dialog box will open. You can change such things as the color, fill, size and shapes of lines.

**Bright Idea**  
For large graphic images, try setting the picture property to **Interlace**. This will cause your images to download partially and then gradually fill in the details. This is a much nicer effect than waiting for large images to download. Double click on the image and select PICTURE FILE TYPE from the General tab. Select INTERLACE from the Settings group.
# Utilizing The Picture Toolbar

<table>
<thead>
<tr>
<th><strong>Set transparent color</strong></th>
<th>Transparency allows you to create non-rectangular looking images for web pages so the page, table or cell background color shows through the transparent area. You can use the <strong>Set Transparent Color</strong> tool to make a single color in a .gif (or .png) transparent. This tool does not work well with all images, particularly those with gradients, drop shadows and photos. To make a color transparent, select the image, click the <strong>Set Transparent Color</strong> button, then, with the tip of the tool, click on the specific image color you wish to make transparent. If you select a color in a JPEG, the image will automatically convert to a GIF since JPEGs do not support transparency. When FrontPage converts a graphic to a GIF from a JPEG or other file format, the number of colors in the graphic may be reduced and the file size can increase. The visual quality may also change and not always for the best.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color</strong></td>
<td>When you select an image and click on the <strong>COLOR</strong> button, a drop-down menu appears. You can convert an image to black and white, grayscale or washout.</td>
</tr>
<tr>
<td><strong>Bevel</strong></td>
<td>To give a three-dimensional look to a graphic, select it then click on the <strong>BEVEL</strong> button. This feature is handy if you want to use the graphic as a button.</td>
</tr>
<tr>
<td><strong>Resample</strong></td>
<td>When you enlarge/reduce a digital image, its pixel dimensions are changed and the image should be <strong>Resampled</strong>. When you resample an image that has been made smaller, the number of pixels in an image decreases. When you increase its size, the number of pixels is increased based on the colors in the image. To resample an image after you have resized it in FrontPage, select it and click on the <strong>RESAMPLE</strong> button. Sometimes when an image is resampled, it can lose a significant detail.</td>
</tr>
<tr>
<td><strong>Select, Rectangular, Circular, Polygon Hotspot, Highlight Hotspots</strong></td>
<td>To make a section of an image an active hyperlink, you create an invisible region on it known as a <strong>Hotspot</strong>. An image containing more than one hotspot is called an <strong>Image Map</strong>. Select one of the three hotspot tools, click and drag your mouse button so the shape surrounds the area where you want to place the hotspot. When you release the mouse button after creating a hotspot, the <strong>Insert Hyperlink</strong> dialog box immediately opens so you can enter the hyperlink address. (See page 55 for details.)</td>
</tr>
<tr>
<td><strong>Restore</strong></td>
<td>You can apply several modifications to an image and, if necessary, undo all of them at once by clicking on the <strong>RESTORE</strong> button. It is not possible to restore an image after it has been saved.</td>
</tr>
</tbody>
</table>
Resizing And Aligning Images

Resizing Graphic Images

Once an image is inserted into your web page, you can resize it to achieve the desired effect.

▶ STEPS: To resize an image:

1. Select your image by clicking on it. When selected, it will have eight sizing handles around it.
2. Place your mouse pointer on one of the sizing handles. It will change to a two way arrow.
3. Click and drag to resize the image.

Bright Idea

Dragging one of the corner handles will resize the image proportionately. Dragging one of the four handles that lie between the corner handles will resize only horizontally or vertically, distorting the image.

Caution

Like anything you find as you search the web, you need to be careful when selecting graphics for your web pages. There are many “free” graphics created by people who are willing to share their work with you. They may request you send your URL, or a postcard, e-mail, or contact them first for permission to use their graphics. These graphics are original and are copyrighted. Copyright laws on the web seem difficult to understand. If you did not create graphic image that you found, then you need permission from the owner before you can copy it. Even if a document or image on the web does not have a copyright notice, it is still protected by copyright laws. Many companies take this very seriously. For example, Fox TV network and Disney have a legal teams dedicated to copyright infringement and are very diligent in searching out fan sites that use their images, music and cartoons and will demand that the copyrighted material be removed.
Cropping Images

Cropping an image means that you remove part of the outer edge, thus resizing it without changing the size of the basic image. Use the Cropping tool to remove unnecessary image content.

▸ STEPS: To crop an image:

1. Select the graphic image (handles will appear around the image).
2. On the Pictures toolbar, click on the CROP button. If the Pictures toolbar is hidden, right click the graphic, then click on SHOW PICTURES TOOLBAR on the shortcut menu.
3. Drag the handles of the cropping box to include the part of the graphic that you want to keep.
4. Click on the CROP button again to remove the area outside of the cropping box.
5. After you crop an image, you will be prompted to resave the image when you save the web page. In most cases, you will want to overwrite the original image.

Bright Idea

You can use Microsoft Office Picture Manager (START ➔ PROGRAMS ➔ MICROSOFT OFFICE ➔ MICROSOFT OFFICE TOOLS ➔ OFFICE PICTURE MANAGER) to crop, compress, resize and edit the quality of graphic images. This is a very user friendly image editing program that is available on all Coast Guard computers.
Adjusting Graphic Image Layout

FrontPage 2003 provides you with several tools to help fine tune the layout of a graphic image on your web page or in a table cell. How the text flows around the image, how close the text is to the image and adding an image border to more clearly define the picture will all be important fine tuning steps.

Aligning Images

▲ STEPS: To change the image alignment and text wrapping attributes:

1. Right click the graphic, then select Picture Properties from the shortcut menu.
2. Click on the Appearance tab.
3. Under Wrapping Style, select the option you want.
4. Under Layout, click the Alignment drop-down arrow and choose an option to specify how you want the graphic to be aligned on the page.
5. Click on OK.

Adding Space or Borders around Images

▲ STEPS: To change border and image spacing attributes:

1. Right click the graphic, then select Picture Properties from the shortcut menu.
2. Click on the Appearance tab.
3. Under the Layout Area, in the Horizontal Spacing box, enter how much space, in pixels, you want to display on the left and the right sides of the image.
4. In the Vertical Spacing box, enter how much space in pixels you want to display on the top and bottom sides of the image.
5. To add a border around an image, in the Border Thickness box, enter the border width in pixels. Enter 0 for no border.
6. Click on OK.
Adding Text Alternatives To Images

Certain groups of people will not be able to access images. This includes people with visual impairments, those using the web with images off for greater speed and those using a text-only browser. It is therefore vital that all images on your pages have an appropriate alternative text description.

The idea of the Text Alternative is to provide a text description that conveys the same information that is communicated by the image. The alternative text is used by screen readers and talking browsers to announce the description for a visually impaired user who has no access to the image. If the image on the web page does not show (either because the visitor has turned off images or because of technical difficulties), the text alternative will appear in place of the image. Later in this manual, we will discuss compliance with Section 508 of the U.S. Rehabilitation Act. Providing text alternatives to images is a requirement under this act.

**STEPS:**

To add a text alternative to graphic images:

1. Select the image that you want to add a text alternative.
2. Click on FORMAT ➔ PROPERTIES.
3. Click on the General tab.
4. Under the Alternative Representations area, in the TEXT box, type the text you want to appear for the image.
5. Click on OK.

**Caution**

Even though the Text Alternative is hidden in the code and will only display if the image does not load onto the web page, everyone can still see it by pausing their mouse on top of an image. Spell check does not check the Text Alternative.
Adding Thumbnail Images

A *Thumbnail* is a miniature version of a picture that represents the full size version of the picture. Using thumbnails of graphics on your web page can reduce download time for visitors to the page and allow you to display more images in an organized fashion. Visitors can still see the full size image by clicking the thumbnail.

Thumbnails used to be a very manual and time consuming process. With FrontPage, you can use the Auto Thumbnail tool to create the thumbnail and a hyperlink to the original image in one easy step.

**STEPS:** To create a thumbnail using the Auto Thumbnail tool:

1. Insert a graphic image into your web page.
2. On the **Pictures** toolbar, click on the **AUTO THUMBNAIL** button. If the **Pictures** toolbar is hidden, right click the image, then click on **SHOW PICTURES TOOLBAR** from the shortcut menu.
3. FrontPage creates a thumbnail graphic and a hyperlink to the original full size graphic. You may notice that your thumbnail has a blue border around it. This is because it is a hyperlink to the full size image. To eliminate the border, double click on the thumbnail to open the **Picture Properties** dialog box and set the **BORDER THICKNESS** to 0.

**Bright Idea**

To change the default thumbnail size and other associated settings, click on **MENU ➔ PAGE OPTIONS ➔ AUTOTHUMBNAIL.**
Creating An Image Map

When created, an Image Map divides an image into different areas. Each area is called a Hotspot. You can assign hyperlinks to these hotspots so they will link to different web pages or documents. In Microsoft FrontPage, hotspots can be shaped as rectangles, circles or polygons.

For example, look at the image below. Although it is a single image, clicking on different areas will take you to different web pages.

▶ STEPS: To create a hotspot on an image:

1. Click VIEW ⇒ TOOLBARS ⇒ PICTURES.
2. Click the RECTANGLE HOTSPOT, CIRCLES HOTSPOT or POLYGONS HOTSPOT button on the Pictures toolbar.
3. Position the mouse over the area of the image where you want to create a hotspot, click and drag to draw the hotspot on the image.
4. Locate the file or web page you want the hotspot to link to or type the address of the web page in the Address box.
5. Click OK.
Creating Photo Galleries

A Photo Gallery is a web page that contains a collection of photos arranged in a specific layout. Microsoft FrontPage provides four different layouts that you can use to arrange your graphics.

When you create a gallery, you can add as many photos as you like. You can also add or remove photos at any time. Once you have added a photo to the gallery, a thumbnail of each photo is automatically created. Below each photo in a photo gallery there is space for a caption and description.

▶ STEPS: To create a photo gallery:

1. Place the cursor in the web page where you want to add a photo gallery.
2. Click on INSERT ➔ WEB COMPONENT.
3. In the Component Type list, click on PHOTO GALLERY.
4. In the Choose a Photo Gallery Option list, select the layout you want.
5. Click on FINISH.
6. To add a photo to the photo gallery, click on the ADD button.
Creating Photo Galleries

7. From the **ADD** drop-down menu, choose **PICTURES FROM FILE** or **PICTURES FROM A SCANNER**.
8. Locate and select the file you want, then click on **OPEN**. (*Tip: To select more than one graphic, hold down the [*CTRL*] key on your keyboard and select the graphics you want.*)
9. To rearrange the order of the photos, select the name of the photo, and click **MOVE UP** or **MOVE DOWN**.
10. (Optional) To edit the picture, select the picture and click on **EDIT**.

![](image1)

11. From the **Edit Picture** dialog box, you can adjust the picture size, rotate and crop the picture. Click on **OK** once complete with your edits.
12. (Optional) To add a caption to the picture, select the picture and type a caption at the bottom of the **Photo Gallery** dialog box and, optionally, a description.

![](image2)

13. Format the text if desired using the format options in the dialog box.
14. Click on **OK**.
15. To edit an existing photo gallery, right click anywhere in the photo gallery, then select **Photo Gallery Properties**.
Inserting Video Clips

You can easily insert a Video Clip to any web page. You are able to specify whether the video clip plays by itself or whether it is controlled by the visitor when the web page is open in the browser. The video could be set to play continuously or only for a specific number of times. Use a common video format such as AVI (.avi) so that the video clip can be easily viewed in your visitor’s web browser.

**Inserting Video Clips**

**STEPS:** To insert a video clip:

1. Click where you want to add a video.
2. Click on **INSERT ➔ PICTURE ➔ VIDEO**.
3. In the **Look in** box, locate the folder where the video file is stored. Select the video file you want to add to your web page, then click on **OPEN**.

**Setting Video Properties**

**STEPS:** To set the video properties:

1. Select the video file on the web page.
2. Click on **FORMAT ➔ PROPERTIES**.
3. Click the **Video** tab, then select the options you want.

<table>
<thead>
<tr>
<th>Loop</th>
<th>In the LOOP box, enter the number of times you want to play the video. If you want the video to play continuous, click the <strong>Forever</strong> check box.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Loop Delay</td>
<td>In the LOOP DELAY box, enter the delay time in milliseconds (1/1000 of a second) to set a delay between playbacks.</td>
</tr>
<tr>
<td>On File Open</td>
<td>If you want to play the video whenever the page is loaded in a visitor’s web browser, click the <strong>ON FILE OPEN</strong> option button.</td>
</tr>
<tr>
<td>On Mouse Over</td>
<td>If you want to play the video whenever a site visitor moves the mouse over the video, click the <strong>ON MOUSE OVER</strong> option button.</td>
</tr>
</tbody>
</table>

4. Click on **OK**.

**Bright Idea**

Some web browsers may not be able to play the video. You can display a message that you want to appear on the web page if a visitor’s web browser cannot play the video. Right click on the video and choose **Picture Properties**. On the **General** tab, under **Alternative Representations**, type the message you want to appear on the web page if the web browser cannot play the video.
Web Site Management

In this section, you will learn more about:

- Correcting Accessibility Issues
- Overview Of Publishing A Web Site
- Publishing Files
- Creating A Task List
- Analyzing A Web Site With Reports
- Using Spell Check
Correcting Accessibility Issues

By checking your web pages for accessibility issues and fixing them, you not only improve the site experience for people with disabilities, but you are complying with Section 508 of the Rehabilitation Act.

By using the Accessibility Checker in FrontPage on web pages you create or edit, you can discover issues that are identified as being in conflict with the World Wide Web Consortium Web Content Accessibility Guidelines (WCAG) or the accessibility guidelines for Section 508 of the U.S. Rehabilitation Act. WCAG outlines priorities for making web sites accessible to people with disabilities. Section 508 outlines the U.S. government accessibility standards.

The WCAG guidelines outline two priorities. Priority 1 and Priority 2 guidelines.

- **Priority 1 guidelines** -- One or more groups of users will find it impossible to access information. An example of a solution to a Priority 1 issue is providing a text alternative for every non-text element. A non-text element is a graphic, a Macromedia Flash animation, movie, etc.

- **Priority 2 guidelines** -- One or more groups of users might find it difficult to access information. An example of a solution to a Priority 2 issue is using text rather than images to convey information.

**Compliance with Section 508** requires access to electronic and information technology used by U.S. Federal agencies. Section 508 guidelines are not prioritized, but many are similar to the WCAG Priority 1 and 2 guidelines.

In addition to the different standards listed above, you can choose to show Errors, Warnings or both. You should not publish a web page with any priority 1 errors.

▶ STEPS: To check your web pages or site for accessibility issues:

1. Click on **TOOLS ➔ ACCESSIBILITY**.

   ![Accessibility Checker](image)

2. Under **Check Where**, specify the pages you want to check for accessibility issues.

3. Under **Check For**, specify the accessibility guidelines you want to check for conflicts.

4. Under **Show**, specify the types of items you want to include in the accessibility report.

5. Click on **CHECK**.

6. To create a web page that contains the results of the accessibility check, click on **GENERATE HTML REPORT**.
Overview Of Publishing A Web Site

After you have finished creating your web site, you will need to publish the pages, images and documents to a web server to allow public viewing. Publishing A Web Site generally means copying all of the files that make up a web site to a particular destination. When you are ready to let others view your web site on the World Wide Web or on the Coast Guard intranet, you will use the FrontPage publishing feature to copy the files to the web server.

Usually, you publish your files because you are working with two kinds of web sites: a Local Web Site and a Remote Web Site:

- The **Local Web Site** is the source web site that is open in FrontPage. A local web site can be stored on either a local or shared hard drive or a development/test web server.
- The **Remote Web Site** is the destination site to which you are publishing. Usually, this is the live web server.

Generally, you create files and folders for your web site on your computer or a development web server. When you are ready to let site visitors see your site on the World Wide Web or on the intranet, you publish them to a web server that is maintained by your ESU or an Internet service provider (ISP).

Although it is standard practice to have two copies of your web site (a live copy and a copy that you make changes on), it is also possible that you will have only one web site, the live site. In this case, you will not publish your site. You simply open your live site and make changes as needed.
Publishing Files

By using the FrontPage Publish Web command, you can choose to publish all the files in your web site or choose not to publish a specific web page in your web site. The Publish web command also lets you copy a web site to either a file system location or a web server. When you copy a web site by publishing it, FrontPage maintains all of the hyperlinks and design characteristics.

▶ STEPS: To publish your web site:

1. Open the web that you want to publish to the web server.
2. Click on FILE ⇒ PUBLISH WEB.
3. Type the location (URL) of the web server you want to publish your web pages.
4. Click on OK.
5. In the Enter Network Password dialog box, type the user name and password in the USER NAME and PASSWORD boxes.
6. Click on the PUBLISH button.
7. Click on the DONE button.

Caution

By default, all files are marked for publishing. There may be some files that you do not want to republish. For example, if your web site has a guest book, republishing the guest book file will cause it to be replaced by a blank file. The same applies to any databases that are hosted in your web site. In the Local Web Site pane (or Folder List), right click each file that you do not want to publish, then select DON'T PUBLISH from the shortcut menu.

Bright Idea

To publish a single file, in the Local Web Site pane (or Folder List), right-click on the file that you want to publish, then select PUBLISH SELECTED FILES from the shortcut menu.
Creating A Task List

You can track work on your web site by assigning *Tasks* to people or to workgroups. To eliminate any confusion, FrontPage allows you to associate these tasks with any file on your web site including a web page, a picture, a sound file or another Microsoft Office documents.

**STEPS:**

To view and create tasks:

1. Click on **VIEW ➔ TASKS**. The task view allows you to see all tasks in the current web site.
2. Click on **EDIT ➔ TASKS ➔ ADD TASK** to add a new task.

3. In the **Task Name** box, type the name of the task.
4. In the **Assigned To** box, type or select the name of the person to whom you want to assign the task to.
5. In the **Description** box, type a description of the task.
6. Under **Priority**, select a priority for the task.

**Associate a Task with a File on a Web Site**

You can also assign a task to any type of file on a web site. This can eliminate confusion as to “which” file needs the editing. You can only assign one task to a file at a time.

**STEPS:**

To create a new task and have it associated with a specific file:

1. In the **Folder List**, click the file that you want to associate a task with. (If the Folder List is hidden, click on **VIEW ➔ FOLDER LIST**.)
2. Click on **EDIT ➔ TASKS ➔ NEW TASK**.
3. Complete the **New Task** dialog box as normal.
4. Next to **Associated With**, verify that the file name you want to associate the task with is listed.
5. Click on **OK**.
Creating A Task List

Completing Tasks

Once a task is created, you can edit, delete or mark the task as complete. One very useful feature about tasks that are associated with files is that when you start a task that is associated with a web page, FrontPage opens that page in the Page view for you to edit.

► STEPS: To modify a previously created task:

1. Click on VIEW ⇒ TASKS.
2. Right click on the task and do one of the following:
   - To mark the task as complete, select Mark Complete.
   - To delete a task, select Delete Task.
   - To edit a task, select Edit Task.
   - To start working on a task that is associated with a file, select Start Task.

Bright Idea

By default, the Task view only shows active tasks. If you would like to see a history of all tasks that have been completed, right click in an empty area of the task view window, then select SHOW HISTORY.
Analyzing A Web Site With Reports

Reports in FrontPage 2003 enable you to gather, analyze, and summarize web site data in a variety of reports. Reports are grouped into five categories:

**Site Summary**
The Site Summary reports display an overview of your web site's vital statistics, such as the number and sizes of files and pictures, number and types of hyperlinks, etc.

**Files**
The Files reports display an overview of the age of files, who is working on them and when they were modified or added.

**Shared Content**
A Shared Content reports display information about the features of your web site that work on groups of pages, such as themes, styles, dynamic web templates and shared borders.

**Problems**
The Problems reports display problems with your web site, including broken links, component errors and files that take too long to load.

**Usage**
A Usage reports display information about the visits to your web site, including page hits, browsers used by site visitors, referring URLs, and more. Usage processing must be turned on for the web server (this is disabled on most Coast Guard web servers).

▶ **STEPS:**

1. Click on **VIEW ⇒ REPORT** and select the desired report category and report.

2. (Optional) To save a report, click on **FILE ⇒ SAVE AS**.

3. (Optional) To copy a report, right-click anywhere on the report and select **COPY REPORT** from the shortcut menu.

4. (Optional) To define report criteria (such as what is considered “Old” or “Slow”), click on **TOOLS ⇒ OPTIONS** and make the desired changes on the Reports View tab.
Using Spell Check

The Spell Check electronically scans your page for misspelled words. FrontPage also has an automatic spell checker that will underline any potentially misspelled words with a red wavy line. When running the Spell Check feature, you can choose to spell check a single page or the entire web site.

► STEPS: To check spelling on a page:

1. Click on the SPELLING button on the Standard toolbar, select TOOLS ⇒ SPELLING or press [F7] on your keyboard.
2. When Microsoft FrontPage finds an unrecognized word or a spelling error, in the Spelling dialog box, the word is displayed in the Not In Dictionary dialog box. Do one of the following:
   ▪ To replace the word with a word from the Suggestions list, select the suggested word, then click on CHANGE.
   ▪ To replace all instances of the word, select the suggested word, then click on CHANGE ALL.
   ▪ To correct the word yourself, type the correct word in the Change To box, then click on CHANGE.
   ▪ To correct all instances of the word, type the correct word in the Change To box, then click on CHANGE ALL.
   ▪ If the unrecognized word is correctly spelled, click on IGNORE to ignore this instance of the word.
   ▪ To ignore all instances of this word, click on IGNORE ALL.
   ▪ To add the unrecognized word to your Custom Dictionary, click on ADD.

► STEPS: To run the spell check in an entire web site:

1. From within the Folder List, click on the top level folder.
2. On the Standard toolbar, click on the SPELLING button
3. Under Check Spelling Of, select Entire Web Site.
4. To create a task list and add a task for each page with misspelled words, select the ADD A TASK FOR EACH PAGE WITH MISSPELLINGS check box.
5. Click on START.
# Appendix A: Keyboard Shortcuts

## Work with and Managing Web Pages

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run the accessibility checker.</td>
<td>F8</td>
</tr>
<tr>
<td>Create a new web page.</td>
<td>CTRL+N</td>
</tr>
<tr>
<td>Open a web page.</td>
<td>CTRL+O</td>
</tr>
<tr>
<td>Close a web page.</td>
<td>CTRL+F4</td>
</tr>
<tr>
<td>Save a web page.</td>
<td>CTRL+S</td>
</tr>
<tr>
<td>Print a web page.</td>
<td>CTRL+P</td>
</tr>
<tr>
<td>Refresh a web page; refresh the Folder List.</td>
<td>F5</td>
</tr>
<tr>
<td>Switch between open web pages.</td>
<td>CTRL+TAB</td>
</tr>
<tr>
<td>Switch between open web pages in reverse order.</td>
<td>CTRL+SHIFT+TAB</td>
</tr>
<tr>
<td>Display nonprinting characters.</td>
<td>CTRL+SHIFT+8</td>
</tr>
<tr>
<td>Display HTML tags in Design view.</td>
<td>CTRL+ /</td>
</tr>
<tr>
<td>Find text or HTML on a web page.</td>
<td>CTRL+F</td>
</tr>
<tr>
<td>Find the next occurrence of the most recent search.</td>
<td>F3</td>
</tr>
<tr>
<td>Find the previous occurrence of the most recent search.</td>
<td>SHIFT+F3</td>
</tr>
<tr>
<td>Replace text or HTML on a web page.</td>
<td>CTRL+H</td>
</tr>
<tr>
<td>Check spelling on a web page.</td>
<td>F7</td>
</tr>
<tr>
<td>Look up a word in the thesaurus.</td>
<td>SHIFT+F7</td>
</tr>
<tr>
<td>Cancel an action.</td>
<td>ESC</td>
</tr>
<tr>
<td>Undo an action.</td>
<td>CTRL+Z</td>
</tr>
<tr>
<td>Redo an action that has been undone or repeat an action.</td>
<td>CTRL+Y</td>
</tr>
<tr>
<td>Move through open dialog boxes.</td>
<td>ALT+F6</td>
</tr>
<tr>
<td>Move through open dialog boxes in reverse order.</td>
<td>ALT+SHIFT+F6</td>
</tr>
<tr>
<td>Delete a web page or folder in the Folder List or any dialog box.</td>
<td>DELETE</td>
</tr>
</tbody>
</table>
# Appendix A: Keyboard Shortcuts

## Access and Use Views

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview the current page in a web browser.</td>
<td>F12</td>
</tr>
<tr>
<td>Move between Code, Design, Split and Preview views.</td>
<td>CTRL+PAGE DOWN or CTRL+PAGE UP</td>
</tr>
<tr>
<td>Move between Code and Design panes in Split view.</td>
<td>ALT+PAGE DOWN or ALT+PAGE UP</td>
</tr>
<tr>
<td>Show or hide the Folder List.</td>
<td>ALT+F1</td>
</tr>
<tr>
<td>Rename the currently selected file in the Folder List.</td>
<td>F2</td>
</tr>
<tr>
<td>Move through the AutoFilter settings for the columns in Reports view.</td>
<td>CTRL+T</td>
</tr>
</tbody>
</table>

## Work with Tables, Graphics, and Hyperlinks

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a table.</td>
<td>SHIFT+CTRL+ALT+T</td>
</tr>
<tr>
<td>Select the next cell's content in a table.</td>
<td>TAB</td>
</tr>
<tr>
<td>Select the preceding table cell's content in a table.</td>
<td>SHIFT+TAB</td>
</tr>
<tr>
<td>With the cursor in a cell, extend a selection to adjacent cells in a row.</td>
<td>Hold down SHIFT and press LEFT or RIGHT ARROW repeatedly.</td>
</tr>
<tr>
<td>With the cursor in the top or bottom cell of a column, select a column.</td>
<td>Hold down SHIFT and press UP or DOWN ARROW repeatedly.</td>
</tr>
<tr>
<td>With the graphic selected, create an auto thumbnail.</td>
<td>CTRL+T</td>
</tr>
<tr>
<td>Create a hyperlink on a web page.</td>
<td>CTRL+K</td>
</tr>
</tbody>
</table>
## Appendix A: Keyboard Shortcuts

### Select text and graphics

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select one character to the right.</td>
<td>SHIFT+RIGHT ARROW</td>
</tr>
<tr>
<td>Select one character to the left.</td>
<td>SHIFT+LEFT ARROW</td>
</tr>
<tr>
<td>Select to the end of a word.</td>
<td>CTRL+SHIFT+RIGHT ARROW</td>
</tr>
<tr>
<td>Select to the beginning of a word.</td>
<td>CTRL+SHIFT+LEFT ARROW</td>
</tr>
<tr>
<td>Select to the end of a line.</td>
<td>SHIFT+END</td>
</tr>
<tr>
<td>Select to the beginning of a line.</td>
<td>SHIFT+HOME</td>
</tr>
<tr>
<td>Select one line up.</td>
<td>SHIFT+UP ARROW</td>
</tr>
<tr>
<td>Select one line down.</td>
<td>SHIFT+DOWN ARROW</td>
</tr>
<tr>
<td>Select to the end of a paragraph.</td>
<td>CTRL+SHIFT+DOWN ARROW</td>
</tr>
<tr>
<td>Select to the beginning of a paragraph.</td>
<td>CTRL+SHIFT+UP ARROW</td>
</tr>
<tr>
<td>Select one screen down.</td>
<td>SHIFT+PAGE DOWN</td>
</tr>
<tr>
<td>Select one screen up.</td>
<td>SHIFT+PAGE UP</td>
</tr>
<tr>
<td>Select the entire page.</td>
<td>CTRL+A</td>
</tr>
</tbody>
</table>

### Edit and Move Text and Graphics

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete one character to the left.</td>
<td>BACKSPACE</td>
</tr>
<tr>
<td>Delete one character to the right.</td>
<td>DELETE</td>
</tr>
<tr>
<td>Delete one word to the left.</td>
<td>CTRL+BACKSPACE</td>
</tr>
<tr>
<td>Delete one word to the right.</td>
<td>CTRL+DELETE</td>
</tr>
<tr>
<td>Copy text or graphics.</td>
<td>CTRL+C or CTRL+INSERT</td>
</tr>
<tr>
<td>Cut selected text to the Office Clipboard.</td>
<td>CTRL+X</td>
</tr>
<tr>
<td>Paste the Clipboard contents.</td>
<td>CTRL+V</td>
</tr>
<tr>
<td>Insert a line break.</td>
<td>SHIFT+ENTER</td>
</tr>
<tr>
<td>Insert a non-breaking space.</td>
<td>CTRL+SHIFT+SPACEBAR</td>
</tr>
</tbody>
</table>
# Appendix A: Keyboard Shortcuts

## Format text and paragraphs

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the font type.</td>
<td>CTRL+SHIFT+F</td>
</tr>
<tr>
<td>Change the font size.</td>
<td>CTRL+SHIFT+P</td>
</tr>
<tr>
<td>Apply bold formatting.</td>
<td>CTRL+B</td>
</tr>
<tr>
<td>Apply an underline.</td>
<td>CTRL+U</td>
</tr>
<tr>
<td>Apply italic formatting.</td>
<td>CTRL+I</td>
</tr>
<tr>
<td>Copy formatting.</td>
<td>CTRL+SHIFT+C</td>
</tr>
<tr>
<td>Paste formatting.</td>
<td>CTRL+SHIFT+V</td>
</tr>
<tr>
<td>Remove manual formatting.</td>
<td>CTRL+SPACEBAR</td>
</tr>
<tr>
<td>Center a paragraph.</td>
<td>CTRL+E</td>
</tr>
<tr>
<td>Left align a paragraph.</td>
<td>CTRL+L</td>
</tr>
<tr>
<td>Right align a paragraph.</td>
<td>CTRL+R</td>
</tr>
<tr>
<td>Indent a paragraph from the left.</td>
<td>CTRL+M</td>
</tr>
<tr>
<td>Indent a paragraph from the right.</td>
<td>CTRL+SHIFT+M</td>
</tr>
<tr>
<td>Apply a style.</td>
<td>CTRL+SHIFT+S</td>
</tr>
<tr>
<td>Apply the Normal style.</td>
<td>CTRL+SHIFT+N</td>
</tr>
<tr>
<td>Apply the Heading 1 style.</td>
<td>CTRL+ALT+1</td>
</tr>
<tr>
<td>Apply the Heading 2 style.</td>
<td>CTRL+ALT+2</td>
</tr>
<tr>
<td>Apply the Heading 3 style.</td>
<td>CTRL+ALT+3</td>
</tr>
<tr>
<td>Apply the Heading 4 style.</td>
<td>CTRL+ALT+4</td>
</tr>
<tr>
<td>Apply the Heading 5 style.</td>
<td>CTRL+ALT+5</td>
</tr>
<tr>
<td>Apply the Heading 6 style.</td>
<td>CTRL+ALT+6</td>
</tr>
<tr>
<td>Apply the List style.</td>
<td>CTRL+SHIFT+L</td>
</tr>
</tbody>
</table>
§ 1194.22 Web-Based Intranet And Internet Information.

(a) A text equivalent for every non-text element shall be provided.

(b) Equivalent alternatives for any multimedia presentation shall be synchronized with the presentation.

(c) Web pages shall be designed so that all information conveyed with color is also available without color, for example from context or markup.

(d) Documents shall be organized so they are readable without requiring an associated style sheet.

(e) Redundant text links shall be provided for each active region of a server-side image map.

(f) Client-side image maps shall be provided instead of server-side image maps except where the regions cannot be defined with an available geometric shape.

(g) Row and column headers shall be identified for data tables.

(h) Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers.

(i) Frames shall be titled with text that facilitates frame identification and navigation.

(j) Pages shall be designed to avoid causing the screen to flicker with a frequency greater than 2 Hz and lower than 55 Hz.

(k) A text-only page, with equivalent information or functionality, shall be provided to make a web site comply with the provisions of this part, when compliance cannot be accomplished in any other way. The content of the text-only page shall be updated whenever the primary page changes.

(l) When pages utilize scripting languages to display content, or to create interface elements, the information provided by the script shall be identified with functional text that can be read by assistive technology.

(m) When a web page requires that an applet, plug-in or other application be present on the client system to interpret page content, the page must provide a link to a plug-in or applet that complies with §1194.21(a) through (l).

(n) When electronic forms are designed to be completed on-line, the form shall allow people using assistive technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues.

(o) A method shall be provided that permits users to skip repetitive navigation links.

(p) When a timed response is required, the user shall be alerted and given sufficient time to indicate more time is required.

Note to §1194.22: The Board interprets paragraphs (a) through (k) of this section as consistent with the priority 1 Checkpoints of the web Content Accessibility Guidelines 1.0 (WCAG 1.0) (May 5, 1999) published by the web Accessibility Initiative of the World Wide web Consortium: